Smartbox picking up archived messages

What happened?

I have set up a custom Smartbox based on a label, and for messages in the inbox (Mailbox: Inbox). I’ve also tried Mailbox Type is Inbox and Mailbox type is Mail not Archive.

When selecting Mailbox: Inbox it didn’t show any messages.

When selecting Mailbox Type is not Archive it pulled up all emails with the label, even those that had been archived.

What mail provider(s) are you using?


What version of iOS?


What build number of Big Mail?


(You can find this in TestFlight)

Hey Simon, thanks for the report.

Gmail is a little weird in that it doesn’t have a true “Archive” folder. Gmail instead uses an “All Mail” folder which –as you might guess by the name– shows all your mail. When you’re ‘Archiving’ you’re actually moving a message out of your Inbox into All Mail.

It depends on what you’re trying to achieve, but perhaps one way would be to filter on the Inbox instead (e.g. is not in my inbox, therefor it’s archived).

If you have a bit more detail on what you’re trying to achieve I can suggest some rules that may work.

Hi! Thanks for your response. I’m trying to create a Smartbox for emails labelled NCE that are in my inbox and not archived. I’ve tried label NCE and Mailbox Inbox, but this doesn’t bring in any emails. I’ve tried Label NCE and Mailbox type is inbox but this doesn’t return anything. I’ve tried label NCE and mailbox type is not archive but this returns emails from my inbox and those that have been archived (moved out of inbox). Any suggestions you have much appreciated! Thanks.

So I went to try this myself…and you’re right it’s not working as expected :man_facepalming:

Taking a look through the code it seems mailbox filters got a bit ‘over optimised’ a few builds ago and is no longer coalescing multiple mailboxes correctly (labels are just mailboxes under the hood).

We’ll get this fixed asap. Thanks!

1 Like